Laboratorium jaringan komputer fakultas teknik



Download 26.37 Kb.
Date conversion31.05.2016
Size26.37 Kb.

LABORATORIUM

JARINGAN KOMPUTER FAKULTAS TEKNIK


UNIVERSITAS TRUNOJOYO 2009 – 2010

MODUL IV

DYNAMIC ROUTING USING OSPF



  1. DESCRIPTION (MATERI)

1. Objective

Objective: Configure OSPF on the network



  • Understand the concepts of OSPF routing protocol

  • Configure dynamic routing protocol using OSPF

  • At last, u know that networking is not easy, not just cabling and ip address and all device will operate on ur mind. Networking need skill and more skills, need to study hard.

2. Background Reading


Go to the Cisco website, or use the Cisco Sybex publication, and read about dynamic routing with OSPF. You can read following tutorial to understand OSPF, we have downloaded that from Cisco website.

OSPF configuration includes only a few required steps, but it has many optional steps. After an OSPF design has been chosen—a task that may be complex in larger IP internetworks—the configuration may be as simple as enabling OSPF on each router interface and placing that interface in the correct OSPF area.

This section shows a simple configuration example of a single-area OSPF internetwork. For reference, the following list outlines the configuration steps as well as a brief reference to the required commands:

Step 1

Enter OSPF configuration mode for a particular OSPF process using the router ospf process-id global command.

Step 2 (Optional)

Configure the OSPF router ID by:

        1. Configuring the router-id id-value router subcommand.

        2. Configuring an IP address on a loopback interface.

Step 3

Configure one or more network ip-address wildcard-mask area area-id router subcommands, with any matched interfaces being added to the listed area.

Step 4 (Optional)

Change the interface Hello and Dead intervals using the ip ospf hello-interval time and ip ospf dead-interval time interface subcommands.

Step 5 (Optional)

Impact routing choices by tuning interface costs as follows:

        1. Configure costs directly using the ip ospf cost value interface subcommand.

        2. Change interface bandwidths using the bandwidth value interface subcommand.

        3. Change the numerator in the formula to calculate the cost based on the interface bandwidth, using the auto-cost reference-bandwidth value router subcommand.

Step 6 (Optional)

Configure OSPF authentication:

        1. On a per-interface basis using the ip ospf authentication interface subcommand.

        2. For all interfaces in an area using the area authentication router subcommand.

Step 7 (Optional)

Configure support for multiple equal-cost routes using the maximum-paths number router subcommand.

OSPF Single-Area Configuration

OSPF configuration differs only slightly from RIP configuration when a single OSPF area is used. The best way to describe the configuration, and the differences with the configuration of the other routing protocols, is to use an example. Following Figure shows a sample network, and code shows the configuration on Albuquerque.



interface ethernet 0/0

ip address 10.1.1.1 255.255.255.0

interface serial 0/0

ip address 10.1.4.1 255.255.255.0

interface serial 0/1

ip address 10.1.6.1 255.255.255.0
!

router ospf 1

network 10.0.0.0 0.255.255.255 area 0

The configuration correctly enables OSPF on all three interfaces on Albuquerque. First, the router ospf 1 global command puts the user in OSPF configuration mode. The router ospf command has a parameter called the OSPF process-id. In some instances, you might want to run multiple OSPF processes in a single router, so the router command uses the processid to distinguish between the processes. The process-id does not have to match on each router, and it can be any integer between 1 and 65,535.

The network command tells a router to enable OSPF on each matched interface, discover neighbors on that interface, assign the interface to that area, and advertise the subnet connected to each interface. In this case, the network 10.0.0.0 0.255.255.255 area 0 command matches all three of Albuquerque's interfaces because the OSPF network command matches interfaces using an address and a wildcard-style mask like those used with IP ACLs. The wildcard mask shown in above example is 0.255.255.255, with address 10.0.0.0. This combination matches all addresses that begin with 10 in the first octet. So, this one network command matches all three of Albuquerque's interfaces, puts them in Area 0, and causes Albuquerque to try to discover neighbors on those interfaces. It also causes Albuquerque to advertise the three connected subnets.

The next example shows an alternative configuration for Albuquerque that also enables OSPF on every interface. In this case, the IP address for each interface is matched with a different network command. The wildcard mask of 0.0.0.0 means that all 32 bits must be compared, and they must match—so the network commands include the specific IP address of each interface, respectively. Many people prefer this style of configuration in production networks, because it removes any ambiguity about the interfaces on which OSPF is running.

interface ethernet 0/0

ip address 10.1.1.1 255.255.255.0

interface serial 0/0

ip address 10.1.4.1 255.255.255.0

interface serial 0/1

ip address 10.1.6.1 255.255.255.0

!

router ospf 1



network 10.1.1.1 0.0.0.0 area 0

network 10.1.4.1 0.0.0.0 area 0



network 10.1.6.1 0.0.0.0 area 0


  1. BEGINNING ASSESMENT (TUGAS PENDAHULUAN )

    1. Describe Dynamic Routing Using OSPF !

    2. Give the example of command in Dynamic Routing Using OSPF and explain !




  1. PRACTICUM (PRAKTIKUM)

A. REQUIRED EQUIPMENT (ALAT & BAHAN)

    1. Two established LANs

    2. Multiple routers depend on router specification, chek your router list in Boson Network Designer

    3. Cables (not used in virtual lab)


B. PROCEDURE LIKE IN LAB 3 (LANGKAH-LANGKAH)
C. QUESTION ( PERTANYAAN )

    1. Delete previous routing protocol configuration, use sh ip ro to see your active routes installed in router.

    2. Use design of sample lab C and try to configure all router using OSPF routing protocol

    3. With design of FT Unijoyo Network, add OSPF routing protocol at all Lab router to connect one to each other. Don’t give OSPF to FT router. Use ping, and tracert to check your configuration.

    4. Instructor’s assignments.



The database is protected by copyright ©essaydocs.org 2016
send message

    Main page